Jump to content
  • 0
Sign in to follow this  
TeeZ

Pierwsza aplikacja, na start problemy.

Question

Hej,

 

Próbuję coś wykombinować na podstawie -> http://www.invisionpower.com/support/guides/_/advanced-and-developers/application/start-here-creating-an-application-r145

 

I mam kilka pytań:

 

Gdzie mam dokładniej wrzucić skin_helloworld.php? Gdy wrzucam do cache/skin_cache/skin_(np)1 to nie odnajduje go w szablonie o ID 1 na liście. Mam inny układ niż na screenie, ale to pewnie wina starszej wersji skryptu na screenach.

To samo mam z lang, może mam to jakość zainicjować w skrypcie? Nie rozumiem.

Skoro pliki od szablonu daję tam ( do skin_cache[...] ) to po co folder skin_cp?

 

Tutaj mój mysection.php

 

<?php

class public_helloworld_example_mysection extends ipsCommand
{
    public function doExecute( ipsRegistry $registry )
    {
        $this->lang->loadLanguageFile( array( 'public_lang' ), 'helloworld' );

        $this->registry->output->setTitle( $this->lang->words['hello_world_title'] );
        $this->registry->output->addNavigation( $this->lang->words['hello_world_title'], NULL );
        $this->registry->output->addContent( $this->registry->output->getTemplate('helloworld')->helloWorld() ); //GDY TAK JEST, TO WYŚWIETLA BŁĄD. GDY USUNĘ TĄ LINIJKĘ TO BŁĘDU NIE MA, BO WŁAŚNIE NIE POBIERA TEGO BITU.
        $this->registry->output->sendOutput();
    }
}

 

 

Kolejne, z którym od zawsze mam problem. Gdy ustawię DEV na 1 mam błędy np.

 

 

Fatal error: Call to a member function userHoverCard() on a non-object in C:\xampp\htdocs\f\admin\sources\base\ipsMember.php on line 169

 

Na stronie głównej, w panelu admina jest ok.

 

W jaki sposób dodać menu? Dla przykładu chcę cos podobnego jak było w przypadku tworzenia hooków, bo potrzebuję umieścić tam pola typu 'Host', 'Haslo', aby to później wyświetlić w kodzie, podczas łączenia z bazą.

Edited by TeeZ

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0

Recache Apps & Modules? Jeżeli tak, to nic nie dało. :read:

Share this post


Link to post
Share on other sites
  • 0

18318367106449696751.png57953279161330343940.png

 

 

 

Cache przebudowałem.

Share this post


Link to post
Share on other sites
  • 0

hmm dziwne. jeśli moduł jest dodany do admina, i istnieje ten plik to po przebudowaniu cache, zawsze się wyświetla to menu u mnie... musiałeś coś skopać nie ma siły :P

Share this post


Link to post
Share on other sites
  • 0

Chciałem sprawdzić jak będzie po reinstalacji.. Straciłem plik z langiem. :| Aż mi się teraz wszystkiego odechciało.

Share this post


Link to post
Share on other sites
  • 0

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

W celu świadczenie usług przez nasz Serwis na najwyższym poziomie, w ramach Serwisu wykorzystujemy pliki Cookies (tzw. ciasteczka). Korzystając ze stron Serwisu IPSBEYOND.PL bez zmiany ustawień przeglądarki będą one zapisane w pamięci urządzenia. Jeżeli nie dokonacie Państwo zmiany ustawień przeglądarki internetowej to wyrażacie zgodę na zapisywanie plików Cookies.