Skocz do zawartości
cichy

(BBR23)Forum Icons

Polecane posty

(BBR23)Forum_Icons_v2.3.0

Jest taki problem ogólnie mod działa ale tylko z obrazami .gif jak mu zapodam .png to nie wyświetla się ikona. A wiem że powinna jakaś rada ?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

tak, musisz zmienić wpis w pliku, ponieważ podczas wyświetlania ikon mod bierze coś takiego

otwórz plik ./sources/classes/class_forums.php

znajdź:


if($forum_data['icon']){
return $forum_data['last_post'] > $rtime ? "<img src=\"".$this->ipsclass->vars['board_url']."/html/forumicons/".$forum_data['icon'].".gif\">"
: "<img src=\"".$this->ipsclass->vars['board_url']."/html/forumicons/".$forum_data['icon']."_off.gif\">";
}else{
return ( $forum_data['last_post'] && $forum_data['last_post'] > $rtime ) ? "<{C_ON".$sub_cat_img."}>" : "<{C_OFF".$sub_cat_img."}>";
}[/php]

i zamienić gif na png inaczej się nie da. chyba, że chcesz to mogę dorobić kod, który będize sprawdzać, czy jest plik gif, a jeśli nie to bierze png

oraz otwórz ./sources/action_admin/forums.php

Znajdź:

[php]if($icon != '.' || $icon != '..') {
$iconname = str_replace(".gif","",$icon);
$icons[] = array($iconname, $iconname);

i także zamień gif na png

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Gość
Temat jest zablokowany i nie można w nim pisać.

  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×

Ważne informacje

Kontynuując przeglądanie strony, wyrażasz zgodę na używanie przez nas plików cookies.