Skocz do zawartości
  • 0
KaLu

Konfiguracja paneli - błąd

Pytanie

Cześć. Wgrałem moduł paneli gracza, wszystko okej, ale po instalacji modułu z pozycji ACP mam następujący błąd:

Warning: Invalid argument supplied for foreach() in /home/worldrp/public_html/kalu/acpeco/sources/base/core.php on line 2698

Linijka w pliku core.php to:


	 foreach( ipsRegistry::$modules[$app] as $_m )

Zaś cały większa część kodu:

    static public function moduleIsEnabled( $module, $app='' )

    {

	 $app = $app ? $app : ipsRegistry::$current_application;


	 foreach( ipsRegistry::$modules[$app] as $_m )

	 {

	  if ( $_m['sys_module_key'] == $module )

	  {

	   return $_m['sys_module_visible'] == 1;

	  }

	 }


	 // Undefined, retun true

	 return TRUE;

    }

Jakieś rady? :unsure:

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

8 odpowiedzi na to pytanie

Polecane posty

  • 0

Okej, problem z panelami rozwiązałem, jednakże mam kolejny. Tym razem po imporcie plików powrotnych do ACP nie czyta mi wyglądu etc.

1558561049.PNG

Jakieś rady? :P

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Co to są pliki powrotne ? odśwież przez ctrl+f5. Może nie wczytuje Ci jakichś stylów bo jest błąd?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Bo je najpierw musiałem wyciągnąć z FTP, pozmieniac parę rzeczy (na domówce pykało) i wgrać. Po wgraniu mam takie coś. Internet mam szybki, więc wątpię, by była to wina cookies lub odświeżania strony.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

1. Szybkość internetu nie ma tu nic wspólnego

2. Skoro coś tam zmieniałeś to może coś skopałeś? może np. style odwołują się do localhosta a nie do serwera gdzie jest forum ?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Wątpię. Konfigurację etc. zmieniłem. Cały styl forum jest w pełni sprawny, jednakże samo ACP ma jakiś błąd.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

No to musisz sobie radzić sam. Niestety ale wróżką nie jestem i bez zobaczenia tego nie jestem w stanie pomóc. Skoro twierdzisz, że wszystko jest ok i nic nie popsułeś to ja w ciemno nie dam rady pomóc.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

W sumie, to znalazłem taki warning:

Twój katalog na zdjęcia jest niezapisywalny

Proszę sprawdzić uprawnienia do katalogu zdjęć '/home/lpp/public_html/uploads/profile/' i upewnić się, że posiada prawa do zapisu.

Może to mieć coś do rzeczy?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Nie, przez ten błąd co najwyżej nie wgrasz zdjęcia profilowego na forum. Ale do ACP to nie ma nic

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×

Ważne informacje

Kontynuując przeglądanie strony, wyrażasz zgodę na używanie przez nas plików cookies.