Skocz do zawartości

Polecane posty

mervin    0

Witam,

czy istnieje możliwość zmiany linków seo z /index.php?/forum/2-a-test-forum/ jakie są obecnie na /forum/2-a-test-forum/? (skasować "index.php?" z adresu)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Spanner    4247

Witaj, oczywiście :) przed chwilą na testowym forum wywaliłem index.php.

Wejdź do ACP -> System Settings -> Zakładka system -> Server Environment -> i w sekcji Friendly URL Features musiszisz ustawić na Yes (zielone pole) Use .htaccess mod_rewrite po tym zabiegu jak umieścisz to co się tam znajduje w pliku .htaccess zniknie index.php? z ciągu zapytania.

Oczywiście w pliku .htaccess musisz umieścić

<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !\..+$
RewriteRule . /index.php [L]
</IfModule>[/code]

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
mervin    0

dzięki. nie udało mi się tego znaleźć wcześniej. Wiesz może czy można skasować także /forum/ z adresu?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Spanner    4247

tego już raczej nie, bo on po tym rozpoznaje co chcesz przeglądać, bo jak wejdziesz w temat to zamiast napisu forum będzie topic, a jak wejdziesz w profil użytkownika to będzie member

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Dzeju    0

Witam

Zrobiłem wg. instrukcji i nie działa u mnie na forum :(

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Dzeju    0

Tak, jest włączona domyślnie. ( takie informację mam od admina)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Spanner    4247

i po wklejeniu:

<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !\..+$
RewriteRule . /index.php [L]
</IfModule>[/code]

do .htaccess znajdującego się w folderze głównym forum nadal nie działa ?? a w ACP wybrałeś odpowiednią opcje jeszcze ??

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Dzeju    0

Tak zaznaczyłem to co w instrukcji, wrzuciłem .htaccess nadal lipa;/

Kidy zaznaczam "Use .htaccess mod_rewrite" na "Tak" to strona główna forum mi działa jednak kiedy che wejść do jakiegoś działu mam błąd 404 wie co jest nie tak ?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Spanner    4247

a czy masz jeszcze jakieś inne swoje regułki w .htaccess ?? bo miałem parę dni temu taki sam problem i się okazało, że dałem w złym miejscu jedną regułkę i przez to się wykrzaczał, ale zmieniłem w niej format dopasowania i zadziałało

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Spanner    4247

Ponieważ adres twojego forum to:

http://respecthh.pl/forum/
więc jak wchodzisz w jakieś forum to masz dodane jeszcze jedno forum. Jak wejdziesz w jakiś temat to będziesz miał
http://respecthh.pl/forum/topic/

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Gość
Temat jest zablokowany i nie można w nim pisać.

  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×

Ważne informacje

Kontynuując przeglądanie strony, wyrażasz zgodę na używanie przez nas plików cookies.