Skocz do zawartości

Polecane posty

Witam

Bardzo ważna sprawa. Jest jakikolwiek sposób aby filmy z youtube były wyświetlane w FlowPlayerze ?

TUTAJ są wszystkie potrzebne informacje jak zainstalować odtwarzacz na stronie jednak czy jest możliwość zmodyfikowania bbcode youtube na tyle by filmy były wyświetlane w FlowPlayerze?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Witaj,

musisz edytować media youtube w ACP i zamienić kod:

<object width="425" height="355"><param name="movie" value="http://youtube.com/v/$2"></param><param name="wmode" value="transparent"></param><embed src="http://youtube.com/v/$2" type="application/x-shockwave-flash" wmode="transparent" width="425" height="355"></embed></object>
na:

<a
href="http://youtube.com/v/$2"
style="display:block;width:425px;height:300px;"
id="player">
</a>

<script language="JavaScript">
flowplayer("player", "path/to/the/flowplayer-3.2.7.swf");
</script>[/code] oraz w globalTemplate przed </head> wstaw:
[code]
<script src="path/to/the/flowplayer-3.2.6.min.js"></script>

i może będzie działać :)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Tak więc w mediatagu mam:

<a 

        href="http://youtube.com/v/$2" 

        style="display:block;width:425px;height:300px;" 

        id="player">

</a>


<script language="JavaScript">

        flowplayer("player", "http://cybstrzaki.com/flowplayer/flowplayer-3.2.7.swf");

</script>
w globalTemplate przed head mam wstawione
<script src="http://cybstrzaki.com/flowplayer/example/flowplayer-3.2.6.min.js"></script>

i niestety film się nie wyświetla... przykład:

775292-75201154447pm.png

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

A jaki adres Ci się wygenerował w playerze? Czy nie ma błędu JS ? posiadasz bibliotekę jQuery? bo ona jest wymagana zapewne do działania tej biblioteki

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

jQuery na serwerze? Gdzie jej mogę szukać? Jeżeli jej nie mam to skąd ją pobrać?

Żaden adres na playerze mi się nie wyświetlał, bo sam player się nie pokazał (tylko puste miejsce które powinien zająć). Po kliknięciu na to miejsce przenosiło do filmu na youtube.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Witam,

poszukaj na forum a znajdziesz jak zainstalować jQuery na forum

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Znalazłem TO, ale nic konkretnego mi to nie mówi...

Trzeba czekać troszkę na twoją odpowiedź więc byłbyś miły mi podać konkrety =D Przepraszam

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

W globalTemplate w tagach <head> dodałem:

<script src="prototype.js"></script>

   <script src="http://cybstrzaki.com/jquery-1.6.2.js"></script>

   <script>

     jQuery.noConflict();


     // Use jQuery via jQuery(...)

     jQuery(document).ready(function(){

       jQuery("div").hide();

     });


     // Use Prototype with $(...), etc.

     $('someid').hide();

   </script>

(prototype.js nie znalazłem na stronie jQuery)

Co mi to dało? Strona po kilku sekundach znika, po prostu znika, czarny ekran.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

wydaje mi sie, ze jeszcze cos jest nie tak w tagu BBCode

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Dopasowanie zamiennika media

http://(\w+.|)youtube.com/watch?v=([^&]+)([^$]*)
Zamienniki HTML mediów
<a 

        href="http://youtube.com/v/$2" 

        style="display:block;width:425px;height:300px;" 

        id="player">

</a>


<script language="JavaScript">

        flowplayer("player", "http://cybstrzaki.com/flowplayer/flowplayer-3.2.7.swf");

</script>

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

@Duke_ tutaj jest wszystko ok.

@Daniel a jesteś pewien że ten FlowPlayer pozwala oglądać filmy z youtube? Błąd mówi, że pod tym adresem nie ma źródła. Nie wiem czy pod takim adresem youtube nie serwuje czasem całego odtwarzacza itp. Wtedy trzeba by wyłuskać sam adres stream'a

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Dzięki wszystkim za pomoc, poradziłem sobie jakoś. Zamiast flowplayera użyłem jw playera

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Gość
Temat jest zablokowany i nie można w nim pisać.

  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×

Ważne informacje

Kontynuując przeglądanie strony, wyrażasz zgodę na używanie przez nas plików cookies.