Skocz do zawartości
  • Zarejestruj się
Lawliet

News Bot

Polecane posty

Przeczytałem temat założony przez Kombajna, ale nie dowiedziałem się niczego więcej niż to, że działa on na zasadzie importu rss'ów z wybranej strony. Mój problem polega na tym, że nie wiem jak dodać tego bota, jak to zrobić.

Chciałbym aby na mojej stronie hasał sobie bot i z wybranej strony umieszczał linki do danego działu. Stworzyłbym dla niego sztucznego usera, ale pytanie jak dodać tego bota, kieruję do was.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Masz opcje importowania RSS, wejdź tam, ustaw co trzeba, skąd ma importować, gdzie i przez kogo, gotowe.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

A samego News Bota (konta z którego będzie pisane) to tworzysz zwykłego usera, moderatora, admina czy kogo tam chcesz :)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Okey, już wiem jak dodać stronę, aby rss'y były importowane bez pośrednio z niej. Teraz - jak połączyć to ze sztucznych użytkownikiem? ( z userem, którego stworzę )?

Jak bot pobiera artykuły? Jeżeli dam link na o2.pl to czy on będzie dokładnie je pobierać?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Tam masz do bólu wszystko wyjaśnione, po prostu przeczytaj ;)

Np:

Autor postów

Artykuł RSS zostanie napisany na forum przez tego użytkownika (nazwa wyświetlana)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

A jak wchodzisz na ten adres RSS'a to działa bez problemu ?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

A ja walidując w ACP kanał news.xml mam:

Wynik walidacji dla

· Kod statusu HTTP: 200 ()

· Kodowanie kanału RSS to windows-1250

· Znaleziono 1 kanałów RSS.

· Znaleźliśmy artykułów/tematów w kanale RSS.

· Znaleziono niepoprawną datę w artykule RSS -- użyty zostanie aktualny czas.

Czyli wszystko ok

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

A u mnie nie pójdzie ani teraz ani przedtem gdy dał screena.


Wyniki weryfikacji dla kanału

 · Kod statusu HTTP: 200 ()

 · XML error: Invalid document end at line 2
A przy rss.asp
Wyniki weryfikacji dla kanału

 · Kod statusu HTTP: 200 ()

 · XML error: Invalid character at line 3
Przy czym test mojego forumowego RSSa przebiega prawidłowo i...
Wyniki weryfikacji dla kanału

 · Kod statusu HTTP: 200 ()

 · Kodowanie kanału to iso-8859-2.

 · Znaleziono 1 kanałów w wybranym RSS.

 · Znaleziono 60 artykułów w kanale RSS.

I takie to buty, niezbadane są ścieżki IPB :P

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

rss.asp to tylko strona z inkami. poprawne rss znajdują się na tej stronie i mi one działają :)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Zobacz co napisał Spanner powyżej.

Edytowano przez Kombajn

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Wyniki weryfikacji dla kanału

· Kod statusu HTTP: 200 ()

· Kodowanie kanału to windows-1250.

· Znaleziono 1 kanałów w wybranym RSS.

· Znaleziono 20 artykułów w kanale RSS.

Działa jak talala

Spanner mówił o tym: http://www.gry-online.pl/rss.asp

Masz tam 7 linków RSS, wszystkie działają, sprawdziłem.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

No to nic więcej nie poradzę, specjalnie przedtem sprawdziłem wszystkie linki po kolei aby Ci przekazać pewną informację, ze działają o czym zresztą też wcześniej mówił Spanner ;)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Ale ze screenu wynika, że znowu dajesz adres rss.asp a to nie jest kanał RSS tylko strona ze spisem. Kanały RSS, które działają masz na tamtej stronie i ich musisz użyć

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Nic nie przychodzi mi już do głowy w Twojej sprawie.

Sprawdziłem teraz ponownie i to na dwóch forach opartych na IPB 2.3.6 i 3.0.5

Na obu linki śmigają.

Info z 2.3.6, sprzed kilku sekund.

Validation Results for http://www.gry-online.pl/rss/news.xml

· HTTP Status Code: 200 (OK)

· The RSS feed's charset is windows-1250

· We found 1 channel(s) in the RSS feed.

· We found 20 article(s)/topic(s) in the RSS feed.

Może masz nulled, w nich często coś nie działa.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

XML error: unknown encoding at line 1

- przy dodawaniu rss'a

Błąd w kodowaniu? Nie poprawne kodowanie?

( pliki są w porządku )

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Kodowanie nie ma tu chyba nic do rzeczy(z takim monitem), jak ustawisz złe kodowanie to po prostu będziesz miał krzaki w postach.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Problem został rozwiązany.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Gość
Temat jest zablokowany i nie można w nim pisać.

  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×

Ważne informacje

W celu świadczenie usług przez nasz Serwis na najwyższym poziomie, w ramach Serwisu wykorzystujemy pliki Cookies (tzw. ciasteczka). Korzystając ze stron Serwisu IPSBEYOND.PL bez zmiany ustawień przeglądarki będą one zapisane w pamięci urządzenia. Jeżeli nie dokonacie Państwo zmiany ustawień przeglądarki internetowej to wyrażacie zgodę na zapisywanie plików Cookies.