Skocz do zawartości
Aniol

Shoutbox - ustawienie miesiąca

Polecane posty

Aniol    0

Proszę mi powiedzieć, w jaki miejscu mogę zmienić nazwę miesiąca z October na Pażdziernik w oknie shoutbox'a

Screen:

etinpl-1286956638-U1.png

Dziękuję za pomoc.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Spanner    4247

Witaj,

ACP -> zakładka System -> System Settings -> zakładka IP.Shoutbox -> Global Configuration -> tam masz opcję Long time format w której ustawiasz format, ale jeśli pozostałe daty na forum masz po Polsku to tutaj także powinno być po polsku. Na tym forum ustawiłem tylko locale w ustawieniach języka na pl_PL.utf-8 (w Twoim przypadku pl_PL.iso-8859-2) i musi działać jak należy

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Aniol    0

Więc tak:

Zmieniłem w ACP w Językach -> na pl_PL.iso-8859-2

Nazwa miesiąca zmieniła się na etinpl-1286963304-U1.jpg, czyli mamy krzaki.

W config global mam ustawione:

$INFO['sql_charset'] =   'latin2';

a w ACP zakładka Ustawienia: Server Environment utf-8, bo jak zmienię na iso to mam krzaki ;/

I o co tu chodzi ? jaki plik edytować aby poprawić to pa?dziernik xD?

Dzięki za pomoc.

Pozdrawiam

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Spanner    4247

A no to mój błąd, zasugerowałem się tym, zę pisałeś gdzieś że masz w iso-8859-2 i stąd tak napisałem. Skoro Server Environment masz na utf-8 to locale też powinno być na utf-8, czyli pl_PL.utf-8

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Aniol    0

A no to mój błąd, zasugerowałem się tym, zę pisałeś gdzieś że masz w iso-8859-2 i stąd tak napisałem. Skoro Server Environment masz na utf-8 to locale też powinno być na utf-8, czyli pl_PL.utf-8

zmieniłem locale ponownie na pl_PL.utf-8 i znowu mam October w shoutbox i na dole w stopce koło strefy czasowej.

Wtf?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Spanner    4247

Jeśli przy utf-8 masz po angielsku to znaczy, że na serwerze nie są dostępne takie locale i bierze domyślne angielskie. Napisz do administratora serwera, że przy ustawieniu w skrypcie locale na pl_PL.utf-8 wyświetla Ci się po angielsku zamiast po polsku

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Gość
Temat jest zablokowany i nie można w nim pisać.

  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×

Ważne informacje

Kontynuując przeglądanie strony, wyrażasz zgodę na używanie przez nas plików cookies.