Skocz do zawartości
Sorael

Kilka pytan po upgrade

Polecane posty

Witam

Mam kilka waznych dla mnie pytan.

1. Jak dopasowac logo aby dzialalo na kazdej rozdzielczosci ?

2. Jak usunac Board legend na samym dole ? blad2.jpg

3. Mam problem z datami w ostatnim poscie. bladsl.jpg Dodam,ze ten problem mam jedynie na stronie głównej. Proszę o konkretne wskazówki

4. W którym miejscu usunę te 2 belki niebieskie ? blad3.jpg

5. Jak usunac lub zamniec ta lupe ? blad4.jpg

Edytowano przez Sorael

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Ad 1. Musisz mieć logo odpowiednio szerokie i dodatkowo mieć element, który będzie powielany w tle tak aby to wszystko wyglądało jak jedno bardzo szerokie logo

Ad 2. Nie ma tego w standardzie więc strzelam ACP -> zakładka Skiny & Języki -> dany skin -> zakładka Szablony -> Strona główna forum -> boardIndexTemplate

Ad 3. Wgrałeś stary skin z 3.0.x na 3.1.x ? ACP -> zakładka Skiny & Języki -> dany skin -> zakładka Szablony -> Strona główna forum -> boardIndexTemplate Znajdź tam

<ul class='last_post'>

<if test="hideLastInfo:|:$forum_data['hide_last_info']">

<li>{$this->lang->words['f_protected']}</li>

<else />

<ul class="last_post'> ...</ul>
 na:



<ul class='last_post'>

												<if test="hideLastInfo:|:$forum_data['hide_last_info']">

													<li>{$this->lang->words['f_protected']}</li>

												<else />

													<if test="hideDateUrl:|:$forum_data['_hide_last_date']">

														<li>{parse date="$forum_data['last_post']" format="LONG"}</li>

													<else />

														<li><a href='{parse url="showtopic={$forum_data['last_id']}&amp;view=getlastpost" base="public" template="showtopic" seotitle="{$forum_data['seo_last_title']}"}' title='{$this->lang->words['view_last_post']}'>{parse replacement="f_lastpost"}</a> <a href='{parse url="showtopic={$forum_data['last_id']}&amp;view=getlastpost" base="public" template="showtopic" seotitle="{$forum_data['seo_last_title']}"}' title='{$this->lang->words['view_last_post']}'>{parse date="$forum_data['last_post']" format="LONG"}</a></li>

													</if>

													<li><strong>{$this->lang->words['in']}</strong> {$forum_data['last_topic_title']}</li>

													<li>

														<strong>{$this->lang->words['by']}</strong> 

														<if test="lastPosterName:|:isset($forum_data['last_poster_name']) AND $forum_data['last_poster_name']">

															<if test="lastPosterID:|:$forum_data['last_poster_id']">

																<a href='{parse url="showuser={$forum_data['last_poster_id']}" template="showuser" seotitle="{$forum_data['seo_last_name']}" base="public"}' title='{$this->lang->words['view_profile']}'>{$forum_data['last_poster_name']}</a>{parse template="user_popup" group="global" params="$forum_data['last_poster_id'], $forum_data['seo_last_name']"}

															<else />

																{$this->settings['guest_name_pre']}{$forum_data['last_poster_name']}{$this->settings['guest_name_suf']}

															</if>

														<else />

															{$this->lang->words['f_none']}

														</if>

													</li>

												</if>

											</ul>[/code]

Ad 4. Znajdź w ipb_styles.css coś takiego

[code].statistics h2

tam powinien być background z zadeklarowanym obrazkiem

Ad 5. Musisz w /public/style_images/x/ zamienić plik search_icon.png na ten z wersji 3.1.x albo inny obrazek jeśli chcesz

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Wszystko działa. Mam jednak problem z pkt 1 i 4

Nie wiem w którym miejscu dodać ten element powielany i jaki on ma kod.

Co do belek Nie jestem w stanie ich usunać.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

w standardowym skinie to jest klasa branding która ma powielanie

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

ok, to tak. Logo obejmujesz czymś takim jak np

<div class="logo_bg">TUTAJ_LOGO</div>
Następnie w CSS'ie wstawiasz taki kod
.logo_bg {

backtround: url({style_images_url}/logo_bg.png) repeat-x;

height: 100px;

}

Oznacza to że plik logo_bg.png będzie powielany w poziomie. W height wpisujesz wysokość swoje pliku i loga zarazem

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

ok, to tak. Logo obejmujesz czymś takim jak np

<div class="logo_bg">TUTAJ_LOGO</div>

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Kod css wklej w dowolne miejsce najlepiej w ipb_styles.css bo jest wczytywany na każdej podstronie.

A ACP -> zakładka Skiny & Języki -> dany skin -> zakładka Szablony -> Główne Szablony -> globalTemplate

znajdź:

<if test="brandingBar:|:method_exists( $this->registry->output->getTemplate( $this->registry->getCurrentApplication() . '_global' ), 'overwriteHeader' )">

{parse template="overwriteHeader" group="{current_app}_global" params=""}

<else />

{parse template="defaultHeader" group="global" params=""}

</if>

i to obejmij tym divem, lub jeśli ten fragment jest już czymś objęty to można edytować tamte klasy

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Witam

Jednak u mnie to nie działa. Na wysokosc owszem. Ale powielanie na wszystkich rozdzielczosciach nie pasuje :)

Jesli chodzi o pkt 4 nie mam pojęcia jak to usunąć.

Jakieś sugestie do dwóch problemów?

Edytowano przez Sorael

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

co to znaczy nie pasuje ? że obrazek do kitu wygląda ? to musisz dopracować obrazek bo nie każdy Ci będzie od kopa pasować. Co do statystyk to nikt Ci nie pomoże, bo w ciemno się nie da. podaj adres forum, to zerknę firebugiem i będzie dobrze

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Nie w tym rzecz :) Jest tak jak było. Logo w szerokości w niczym się nie zmienia niż przed dodaniem kodu.

Adres: www.fifaplay.com.pl :)

Edytowano przez Sorael

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

co do tego h2 to dodaj w

.statistics h2 
background: transparent !important;

i zniknie to

Ja tam widzę w brandingu obrazek i widzę że jest powielony

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Super pięknie śmiga :) jednak mam kolejny problem chcę zamienić kolor białych napisów blad3.jpg.

Co do loga gdy daje ctrl + lub - nie pasuje mi ucina niestety :) Nie mieści się w skinie, może coś źle napisałem.

Edytowano przez Sorael

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

ctrl+ powiększa rozmiar czcionki. Jeśli chcesz zobaczyć większe rozdzielczości to poszukaj w necie takich stron, które oferują robienie screenów stron lub symulują większe rozdzielczości. Co do koloru czcionki to w

.statistics h2 

ustaw odpowiedni kolor

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Ze wszystkim sobie dałem rade tylko nie z logiem.

logoskin.jpg

Mozna jakos ustawic aby bylo rowno zawsze z ta belka pod logiem ?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

W css (ipb_styles.css) w klasie:

#primary_nav
w background masz
url(...) no-repeat;

Zamień no-repeat na repeat-x i powinno działać

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Gość
Temat jest zablokowany i nie można w nim pisać.

  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×

Ważne informacje

Kontynuując przeglądanie strony, wyrażasz zgodę na używanie przez nas plików cookies.