Jump to content
  • 0

Ucięty content


Question

Autor motywu napisał kod tak:

 

.ipsDataItem_subList a {
    display: inline-block;
    white-space: nowrap;
    max-width: 100%;
    overflow: hidden;
    text-overflow: ellipsis;
    vertical-align: top;
}

Ale gdy zmienię display: inline-block; to content robi się normalny. A gdy jest tak jak w kodzie, ucina 1px z contentu. Czemu? I co tu wpisać, aby było ok?

Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0
  • Administrator

Ja tutaj widzę:

white-space: nowrap;

nie łam spacji

text-overflow: ellipsis;

dodaj ... w css'ie

może to któreś z tych

Link to post
Share on other sites
  • 0
5 minut temu, Spanner napisał:

Ja tutaj widzę:


white-space: nowrap;

nie łam spacji


text-overflow: ellipsis;

dodaj ... w css'ie

może to któreś z tych

Jak nie łam spacji? Nie rozumiem te dwie "funkcje" mam wpisane normalnie. To autor wpisał. To poco ma to być dodane x2?

Edited by michalsky384
Link to post
Share on other sites
  • 0
  • Administrator

jest coś takiego w css. Polega to na tym, że białe znaki (spacja) są interpretowane w ten sposób że jeśli nie mieszczą się w zadanym rozmiarze kontenera np. 100px to standardowo wiersz jest zawijany do następnej linijki. Jak sobie to ustawisz co wyżej, spacja nie powoduje załamania, w związku z czym masz jedną długą linię.

https://www.w3schools.com/cssref/pr_text_white-space.asp

Link to post
Share on other sites
  • 0
8 minut temu, Spanner napisał:

jest coś takiego w css. Polega to na tym, że białe znaki (spacja) są interpretowane w ten sposób że jeśli nie mieszczą się w zadanym rozmiarze kontenera np. 100px to standardowo wiersz jest zawijany do następnej linijki. Jak sobie to ustawisz co wyżej, spacja nie powoduje załamania, w związku z czym masz jedną długą linię.

https://www.w3schools.com/cssref/pr_text_white-space.asp

Dalej nie kapuje. Szukałem białych znaków, nigdzie ich nie ma. Jest taka opcja, że mogę być tępy 😄

Link to post
Share on other sites
  • 0
  • Administrator
12 godzin temu, michalsky384 napisał:

. Szukałem białych znaków, nigdzie ich nie ma

każda spacja to biały znak. Wystarczy że masz "nazwa działu" i tutaj masz biały znak 😛

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Dołącz do pierwszego newslettera Invision Community

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

W celu świadczenie usług przez nasz Serwis na najwyższym poziomie, w ramach Serwisu wykorzystujemy pliki Cookies (tzw. ciasteczka). Korzystając ze stron Serwisu IPSBEYOND.PL bez zmiany ustawień przeglądarki będą one zapisane w pamięci urządzenia. Jeżeli nie dokonacie Państwo zmiany ustawień przeglądarki internetowej to wyrażacie zgodę na zapisywanie plików Cookies.