Skocz do zawartości
  • Zarejestruj się
  • 0
Mateusz_K

Zły adres URL do awatarów użytkowników

Pytanie

Cześć, wiem, że mało kto jeszcze używa IPB w wersji 3.x , ale mam pewien problem. Walczymy z aktualizacją do wersji 4, pomaga nam support IPSu, ale po ostatniej próbie aktualizacji przez nich wywaliło nam forum i musieliśmy wgrywać backup swoich plików i bazy. Niby wszystko wróciło do normy, ale pojawiło się paru userów, którym usunął się awatar. Ale usunął się tylko z profilu, na serwerze zdjęcie istnieje. Ale podejrzałem w sieci i wali błędem, że nie ma takiego pliku. Faktycznie nie ma, bo prowadzi on do folderu uploads/av-xxxx.jpg . A zdjęcia do profilu są w katalogu /uploads/profile/photo-xxxx.jpg . I zdjęcie tego usera istnieje w tym katalogu, ale nie wiem dlaczego nagle zmieniła się ścieżka i prowadzi do innego miejsca 😕 . Tym bardziej dziwne, że wgrana jest baza, która była wcześniej i również wszystkie pliki. Czy ktoś może wie jak można sobie poradzić sobie z tym, żeby jakoś podmienić te ścieżki na dobre ? 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

8 odpowiedzi na to pytanie

Polecane posty

  • 0

Ogólnie brany jest adres, jaki masz w ustawieniach. Tam jest zapewne samo /uploads. Wyjścia jak dla mnie są 2.

1. skopiuj te pliki do katalogu uploads (zalecane)

2. możesz zmienić w pliku /admin/sources/base/ipsMember.php aby brał link z innej lokalizacji

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Lokalizacja jest dobra, bo jak ktoś wgra ponownie avatar to wgrywa się poprawnie i wyświetla. A z tym kopiowaniem do katalogu uploads to też może być uciążliwa sprawa, bo trzeba by było zmieniać też nazwę pliku, a też nie wiem ile jest takich osób.. Bo narazie widzę tylko dwie takie osoby, ale pewnie jest ich więcej. No ale jeśli jest to jedyny sposób to będę musiał z niego skorzystać. Dzięki 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Czemu zmieniać nazwę? nic nie musisz zmieniać. Jeśli pliki są ale w innej lokalizacji to kopiujesz je bez nadpisywania istniejących i wszyscy wszystko mają 🙂

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

No ale przecież teraz on chce się odwoływać do pliku av-xxxxx.jpg a nie photo-xxxxx.jpg . 

I wywaliło też miniatury grafik na podstronie, a już tych plików niestety nie widzę nigdzie na serwerze. 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

no to widzę, że grubo zadziałali 🙂 z nazwami plików to nie problem bo jednym zapytaniem w bazie można zmienić to co użytkownicy mają zapisane.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Tak, pojechali po bandzie 😛 . A że już nie wspierają wersji 3, to cwaniaki się wymigują od naprawy tego, co schrzanili 🙂 . Dobra Ci co nie mieli avatara to przywrócone mają defaultowe, to pojedyncze jednostki, więc nie będę kombinować. Najwyżej wgrają sobie ponownie. Dzięki, można zamknąc. 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0
8 minut temu, Mateusz_K napisał:

A że już nie wspierają wersji 3, to cwaniaki się wymigują od naprawy tego, co schrzanili

Rozumiem to, ale to nie oznacza, że nie powinni naprawić forum, żeby działało w wersji 4 🙂

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Problem został rozwiązany.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Gość
Temat jest zablokowany i nie można w nim pisać.

  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×

Ważne informacje

W celu świadczenie usług przez nasz Serwis na najwyższym poziomie, w ramach Serwisu wykorzystujemy pliki Cookies (tzw. ciasteczka). Korzystając ze stron Serwisu IPSBEYOND.PL bez zmiany ustawień przeglądarki będą one zapisane w pamięci urządzenia. Jeżeli nie dokonacie Państwo zmiany ustawień przeglądarki internetowej to wyrażacie zgodę na zapisywanie plików Cookies.