Skocz do zawartości
  • Zarejestruj się
  • 0
sNaxu

HTTP -> HTTPS

Pytanie

Cześć ponownie. Tym razem mam błąd z https, dokładniej chodzi o to, że automatyczne przekierowanie z http na https działa tylko tylko podczas logowania się do konta i logowania się do ACP. No i gdy forum jest wyłączone. Jakiś pomysł jak to rozwiązać?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

18 odpowiedzi na to pytanie

Polecane posty

  • 0

Witaj,
a co chcesz osiągnąć? mieć cały czas po https? ustawiłeś w conf_global.php adres, żeby był po https? zrobiłeś przekierowanie z http na https w .htaccess?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0
11 godzin temu, Spanner napisał:

Witaj,
a co chcesz osiągnąć? mieć cały czas po https? ustawiłeś w conf_global.php adres, żeby był po https? zrobiłeś przekierowanie z http na https w .htaccess?

Aktualnie forum jest na zwykłym http, chcę aby automatycznie przekierowywało go z http na https, co do conf_global i htacces to zrobiłem zgodnie z poradami wziętymi z "konkurencyjnego" forum, invisione tak jak DawPi pisał.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Aktualnie https działa tylko na logowaniu się do konta i acp

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

To wklej je tutaj. Nie wiem co Ci doradzili tam, ale widocznie coś nie do końca jest ok, skoro nadal nie działa i masz tylko na stronach logowania.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

htaccess

#Ustawienia IP.Board by Amfidiusz
<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteCond %{HTTPS} on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(jpeg|jpg|gif|png)$ /public/404.php [NC,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

</IfModule>

A tutaj conf_global

<?php
$INFO['sql_driver']			=	'mysql';
$INFO['sql_host']			=	'xxx';
$INFO['sql_database']			=	'xxx';
$INFO['sql_user']			=	'xxx';
$INFO['sql_pass']			=	'xxx';
$INFO['sql_tbl_prefix']			=	'';
$INFO['sql_debug']			=	'0';
$INFO['sql_charset']			=	'';
$INFO['board_start']			=	'1520036870';
$INFO['installed']			=	'1';
$INFO['php_ext']			=	'php';
$INFO['safe_mode']			=	'0';
$INFO['board_url']			=	'https://forum.first-rp.pl';
$INFO['banned_group']			=	'5';
$INFO['admin_group']			=	'4';
$INFO['guest_group']			=	'2';
$INFO['member_group']			=	'3';
$INFO['auth_group']			=	'1';
$INFO['use_friendly_urls']			=	'1';
$INFO['_jsDebug']			=	'0';
$INFO['mysql_tbl_type']			=	'MyISAM';

define('IN_DEV', 0);
/* Remote archive DB - complete these details if you\'re using a remote DB for the post archive.
   If content has already been archived in the local DB, this will need transferring and will not be done automatically. */
$INFO['archive_remote_sql_host']			=	'';
$INFO['archive_remote_sql_database']			=	'';
$INFO['archive_remote_sql_user']			=	'';
$INFO['archive_remote_sql_pass']			=	'';
$INFO['archive_remote_sql_charset']			=	'';

?>

 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

No i tam jest pies pogrzebany :)

ogólnie w .htaccess daj takie coś:

RewriteEngine On
RewriteCond %{HTTPS} !on
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301,NC]

To spowoduje, że jeśli jest włączony https to wymusi przekierowanie na https

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Niestety wyskakuje błąd 

Strona forum.first-rp.pl spowodowała zbyt wiele przekierowań.

 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

A w ustawieniach wszystkich w acp itp też masz ustawiony adres na https? bo ogólnie tego używam wszędzie i przekierowań nie ma. choć wersja 3 jest średnio kompatybilna z ssl'em

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0
Napisano (edytowany)

Coś się dziwnego stało bo nawet do ACP nie mogę wejść, lecz na stronę główną tak.

Ta strona nie działa

Strona forum.first-rp.pl spowodowała zbyt wiele przekierowań.

ERR_TOO_MANY_REDIRECTS
Edytowano przez sNaxu

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

To usuń ten wpis w .htaccess

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

No właśnie usunąłem..

#Ustawienia IP.Board by Amfidiusz
<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(jpeg|jpg|gif|png)$ /public/404.php [NC,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

</IfModule>

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

wyczyść sobie cookie dla tej strony albo dane przeglądarki. Zapamiętało Ci przekierowanie 301 i dlatego. Możesz otworzyć tryb incognito, albo inną przeglądarkę i nie będzie tego problemu

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Cały czas jest to samo.. 

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

U mnie działa

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Strona główna działa, ale logowanie się do ACP już nie :/ Próbowałem przez link do dashboarda ale to samo..

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

a jakiś .htaccess do panelu admina? tam nic nie kombinowałeś?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Nie, ustawiłem tylko logowanie się za pomocą https w acp no i tego htaccess z conf_global, wrócę do domu to jeszcze zmienię https na http w conf_global.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Niestety nadal to samo..

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

Bądź aktywny! Zaloguj się lub utwórz konto

Tylko zarejestrowani użytkownicy mogą komentować zawartość tej strony

Utwórz konto

Zarejestruj nowe konto, to proste!

Zarejestruj nowe konto

Zaloguj się

Posiadasz własne konto? Użyj go!

Zaloguj się

  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×

Ważne informacje

W celu świadczenie usług przez nasz Serwis na najwyższym poziomie, w ramach Serwisu wykorzystujemy pliki Cookies (tzw. ciasteczka). Korzystając ze stron Serwisu IPSBEYOND.PL bez zmiany ustawień przeglądarki będą one zapisane w pamięci urządzenia. Jeżeli nie dokonacie Państwo zmiany ustawień przeglądarki internetowej to wyrażacie zgodę na zapisywanie plików Cookies.