Skocz do zawartości
  • 0
pitersc

Jak dodać w sidebar kod PHP z linkami (customowy), najnowsze posty itp

Pytanie

Witam,

Forum www.f650gs.pl - chcę dodać w prawy sidebar

1 najnowsze wątki,

2 najnowsze posty,

3 aktualizacje statusów,

4 total time spent on forum

5 kod php z kodem linków customowy

co do piątego znalazłem to, ale podobno nie wyświetla kodów php, prośba o pomoc w powyższych sprawach.

Dzięki!

PS

czy w fabrycznym 4.1 nie ma już żadnych sidebarów?

PS2

jeżeli pomyliłem działy to prośba o przerzucenie bo nie mam pewności.

Edytowano przez pitersc

Udostępnij ten post


Link to postu
Udostępnij na innych stronach

16 odpowiedzi na to pytanie

Polecane posty

  • 0
13 godzin temu, pitersc napisał:

Ok mam dzięki, fabryczne bloki dodałem natomiast mam problem z wyświetlaniem linków globalnie za pomocą skryptu PHP:

w ipb v3 skrypt chodził w takiej wersji:

<php>
include_once("......php");
$toShow = statlink_show_links("", " | ", "", "");
</php>
{$toShow}

zależy mi na tym by linki były wyświetlane globalnie na całym forum w sidebar, prośba o pomoc

Teraz tego tak nie zrobisz. Najlepiej przerobić to delikatnie na zasadzie takiej:

  1. w katalogu głównym forum tworzysz plik np. plik.php tam umieszczasz tego include i dajesz echo statelink_sho...
  2. w widgecie dajesz taki kod:
    {insert="ścieżka_do_pliku.php"}

     

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 1
12 godzin temu, pitersc napisał:

Dzięki, z kodu html dla reklam wyświetla się sam kod:


{insert="ścieżka_do_pliku.php"}

 

Natomiast jak wklejam kod w globaltemplate to zamiast linków wyświetla: System Reklamy Test    czyli też coś jest nie tak, statlink musi na bieżąco wiedzieć na jakiej stronie się znajduje i boję się, że takie obejście właśnie powoduje problem

a ten kod wstawiasz w co? blok do custom code php&text czy edytor czy co?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 1

tego to ja już nie wiem jak ten system działa, ale ogólnie skoro wyświetla się coś to znaczy że działa. A czy nie pozmieniały Ci się jakieś linki albo coś? bo może u nich jest tak, że dla konkretnych podstron zapisuje dane itp, a tutaj się coś pozmieniało teraz

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Musisz sobie w uprawnieniach grupy admin zmienić, aby mogła zarządzać widgetami. Wtedy wszystki widgety dostępne będą na foncie pod przyciskiem takiej strzałki z lwej strony forum.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Dzięki, przeglądam wszystkie opcje grupy adminów i nie widzę opcji zarządzania widgetami, możesz mnie nakierować?

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Mój błąd.

ACP -> Użytkownicy -> Administracja -> Moderatorzy -> wybierasz i edytujesz grupę admina, i w pierwszej zakładce masz coś takiego: Może zarządzać panelem bocznym? daj na tak i odśwież front a zobaczysz strzałkę z lewej strony

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Ok mam dzięki, fabryczne bloki dodałem natomiast mam problem z wyświetlaniem linków globalnie za pomocą skryptu PHP:

w ipb v3 skrypt chodził w takiej wersji:

<php>
include_once("....php");
$toShow = statlink_show_links("", " | ", "", "");
</php>
{$toShow}

zależy mi na tym by linki były wyświetlane globalnie na całym forum w sidebar, prośba o pomoc

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Dzięki, z kodu html dla reklam wyświetla się sam kod:

{insert="ścieżka_do_pliku.php"}

 

Natomiast jak wklejam kod w globaltemplate to zamiast linków wyświetla: System Reklamy Test    czyli też coś jest nie tak, statlink musi na bieżąco wiedzieć na jakiej stronie się znajduje i boję się, że takie obejście właśnie powoduje problem

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Coś jest w tym nowym silniku IPB, że wydaje mi się że wycina wszystkie dodatkowe kody php, ale może się mylę - no musi być jakiś sposób.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Nawet nie wiem gdzie jest custom code php i jak dodać go do bloków, prośba o podpowiedź.

w global template gdziekolwiek wrzucam byle się coś wyświetliło na testy ale tu właśnie jest problem bo niby działa bo nie wyświetla komendy html tylko "system reklamy test", czyli coś już jest, ale na tym etapie powinno wyświetlać linki.

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Noż w mordę lepszy! czemu ja tego nie znalazłem przez ostatnie 20 godzin!! Proste i doskonałe!

Niestety dalej wyświetla system reklamy test, podpytałem autorów skryptu i odpisali tak:

Cytat

Jedyne co moge powiedzieć to "system reklamy test" powinien pojawiać się przy pustym pliku statlink*_dat.php, jeżeli plik nie jest pusty przy prawidłowej implementacji powinny pojawić się linki. Plik dat jeżeli jest pusty powinien się automatycznie zapełnić w przeciągu 24h.

No u mnie ten plik nie jest pusty - czy może ten kod php wymaga dodatkowej modyfikacji czy to raczej już kwestia problemów z uprawnieniami? uwaga pilna prośba via pw

prawie.jpg

Nawet gdy dodam uprawnienia 777 na pliki statlink php to nadal wyświetla się system reklamy test, może to zgłosić do hostingu, może to blokują?

Edytowano przez pitersc

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

O cholera a jak zrobić by ten blok wyświetlał się na wszystkich podstronach forum?

Co do zmiany linków to dobry trop, zzeruje wszystko w systemie i zobaczymy

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
  • 0

Ok, trzeba rzucić tym blokiem do widoku for i postów i po sprawie. niebywale banalne a ja szukałem w kodzie :)

Udostępnij ten post


Link to postu
Udostępnij na innych stronach
Gość
Temat jest zablokowany i nie można w nim pisać.

  • Kto przegląda   0 użytkowników

    Brak zalogowanych użytkowników przeglądających tę stronę.

×

Ważne informacje

Kontynuując przeglądanie strony, wyrażasz zgodę na używanie przez nas plików cookies.