Jump to content

fala

Members
  • Content Count

    12
  • Joined

  • Last visited

Community Reputation

0 Neutral

About fala

  • Rank
    IP.Board Newbie

Informacje o forum

  • Forum version
    IP.Board 3.1.x
  1. A więc rozwiązałem problem. Okazuję się, że od wersji 3.x ustwia się kodowanie połączenia w pliku config_global.php dodając taki wpis: $INFO['sql_charset'] = 'latin2'; Wszystko działa prawidłowo.
  2. Już nie mam sił... zacznijmy od poczatku... powodem konwersji bazy do UTF-8 były krzaki po aktualizacji do 3.1.4: Sądze teraz, że ma to coś wspólnego z wpisem w pliku class_db_mysql.php. Sprawdziłem, wersja 3.1.4 nie wykorzystuje juz tego pliku tylko plik classDbMysqliClient.php.
  3. dziwne ze baza przekonwertowana na uft8, wpis do pliku class_db latin2 a posty wieswietlaja sie prawidlowo.. po zmiania na uft8 krzoki... Dobra sprawdze jeszcze na orginale w wpisami w class_db. Dam znać o wynikach.
  4. zmeinialem na uft-8 i nic nadal krzaki... :/ ogolnie na wersji 2.1.x po konwersji to UFT-8 bazw wygląda tak: Forum tak: W ACP > UTF-8 Plik config_global.php: <?php $INFO['admin_group'] = '4'; $INFO['auth_group'] = '1'; $INFO['board_start'] = '1021891628'; $INFO['board_url'] = 'http://w7test/forum_domin'; $INFO['conv_configured'] = '1'; $INFO['conv_forums'] = '1'; $INFO['conv_members'] = '1'; $INFO['conv_posts'] = '1'; $INFO['conv_ranks'] = '1'; $INFO['conv_topics'] = '1'; $INFO['default_language'] = 'polski'; $INFO['g
  5. no więc mój plik się nazywa class_db_mysql.php i istnieje w nim kod: mysql_query('SET character_set_connection=latin2', $this->connection_id); mysql_query('SET character_set_client=latin2', $this->connection_id); mysql_query('SET character_set_results=latin2', $this->connection_id); mysql_query("set names latin2;");
  6. mały problem jeszcze jest z wersji 2.1.x po zalogowaniu nie widzi sesji (tzn. caly czas pokazuję zaloguj się...), myslalem ze upgrade to naprawi ale okazuje sie ze jest to samo, ale tylko na forum, ACP bez problemu zapamietuje sesje. Dlatego nie mogę napisać postu aby sprawdzić. Loguje się na konto "admin".
  7. Wiem chyba co jest nie tak, ja widze jakaś strone demotywatorów a ty pewnie wklejasz link do wątku na temat połączenia UTF... hmmmmmmmmmmmmmmmm
  8. powiem Ci, że nie wiem co chcesz przez to rozumieć prosze technicznie bardziej jeśli można.
  9. Tak jak pisałem nad screenem UTF-8 w bazie i UTF-8 na forum w ACP. Co do połączenia chodzi ci o wpis w global_config?
  10. Witam, walcze juz tydzień z aktualizacją dużego systemu z 2.1.5 do 3.1.4. Po aktualizacji w kategroiach i postach pojawiają się krzaczki (znaki zapytania) Kodowanie bazy latin2_general_ci, kodowanie IPB w ACP iso-8859-2. Próbowałem także przekonwertować baze do UTF-8 i potem aktualizacja. Wszystko prawidłowo przebiegło na wersji 2.1.5 pełny UTF-8 działał. Po aktualizacji kategorie i posty krzaki... chodz w phpmyadmin widać prawidłowe kodowanie, i w ACP również: Spróbuję jeszcze przekonwertować baze do UTF-8 po aktualizacji do 3.1.4. Ogólnie brak pomysłów jeśli
×
×
  • Create New...

Important Information

W celu świadczenie usług przez nasz Serwis na najwyższym poziomie, w ramach Serwisu wykorzystujemy pliki Cookies (tzw. ciasteczka). Korzystając ze stron Serwisu IPSBEYOND.PL bez zmiany ustawień przeglądarki będą one zapisane w pamięci urządzenia. Jeżeli nie dokonacie Państwo zmiany ustawień przeglądarki internetowej to wyrażacie zgodę na zapisywanie plików Cookies.