Jump to content

hypexo

Members
  • Content Count

    1
  • Joined

  • Last visited

Seller statistics

  • 0
  • 0
  • 0

Community Reputation

0 Neutral

About hypexo

  • Rank
    IP.Board Newbie

Informacje o forum

  • Forum version
    Invision Community 4.4.x
  1. Hej, Mam problem z NGINX i przyjaznymi linkami, próbowałem przerabiać .htaccess na nginx ale nie poszło tak jak powinno. .htaccess wygenerowany z panelu admina ma taka zawartość: <IfModule mod_rewrite.c> Options -MultiViews RewriteEngine On RewriteBase / RewriteCond %{REQUEST_FILENAME} !-f RewriteRule \.(js|css|jpeg|jpg|gif|png|ico|map)(\?|$) /404error.php [L,NC] RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L] </IfModule> Niby po konwertowaniu kod wygląda tak: location / { if (!-e $request_filename){ rewrite \.(js|css|jpeg|jpg|gif|png|ico|map)(\?|$) /404error.php break; } if (!-e $request_filename){ rewrite ^(.*)$ /index.php break; } } Wrzucałem to do pliku "/etc/nginx/sites-available/default" - bez rezultatu. Zmieniałem również w tym pliku: location / { try_files $uri $uri/ =404; } na location / { try_files $uri $uri/ /index.php?$args; } Również nie przyniosło oczekiwanego efektu. Nadal przy włączonej opcji przyjaznych linków wyskakuje: Czy jest tutaj ktoś kto pomógłby sprostać temu ? Dzięki :)
×
×
  • Create New...

Important Information

W celu świadczenie usług przez nasz Serwis na najwyższym poziomie, w ramach Serwisu wykorzystujemy pliki Cookies (tzw. ciasteczka). Korzystając ze stron Serwisu IPSBEYOND.PL bez zmiany ustawień przeglądarki będą one zapisane w pamięci urządzenia. Jeżeli nie dokonacie Państwo zmiany ustawień przeglądarki internetowej to wyrażacie zgodę na zapisywanie plików Cookies.