Jump to content

VoytechG

Members
  • Content Count

    108
  • Joined

  • Last visited

Posts posted by VoytechG

  1. Hej, ostatnio wywaliło nam solidnie forum. Błąd bazy jaki się pokazuje to:

    Fatal error: Uncaught IPS\Db\Exception: Connection refused in /home/audiostereo/public_html/system/Db/Db.php:262 
    Stack trace: #0 /home/audiostereo/public_html/system/Db/Db.php(349): IPS\_Db->_establishConnection(false) 
    #1 /home/audiostereo/public_html/system/Db/Db.php(480): IPS\_Db->checkConnection(false) 
    #2 /home/audiostereo/public_html/system/Db/Db.php(968): IPS\_Db->preparedQuery('REPLACE INTO `i...', Array) 
    #3 /home/audiostereo/public_html/system/Session/Admin.php(123): IPS\_Db->replace('core_sys_cp_ses...', Array) 
    #4 [internal function]: IPS\Session\_Admin->write('iafafr9oq472mgc...', '') 
    #5 /home/audiostereo/public_html/system/Redis/Redis.php(218): session_write_close() 
    #6 [internal function]: IPS\_Redis->IPS\{closure}(Object(IPS\_Redis)) 
    #7 {main} thrown in /home/audiostereo/public_html/system/Db/Db.php on line 262

    Błąd mógł zostać wywołany przez wtyczkę newsletter (do zliczania kliknięć w wysłanych newsletterach), ale nie jesteśmy co do tego 100% pewni.

    Obecnie został wyłączony serwer apache dlatego pokazuje błąd 502. Ogólnie to ten błąd zepsuł nam wszystkie strony postawione na tej maszynie. Sprawa wygląda poważnie. Jakiś trop?

  2. Wszystko na razie działa, polskie znaki poprawiłem tym poleceniem 

    UPDATE `forum_core_error_logs` SET 
    `log_error` = REPLACE(`log_error` , '¦', 'Ś'),

    a kolumnę "post" ze starej tabeli przekopiowałem do nowej i działa 😄

     

    UPDATE table_name1 
        SET column1 = (
            SELECT column2
            FROM table_name2
            WHERE table_name1.id = table_name2.id
        );
    • Like 1
  3. Cześć, 

    posłużyłem się tym tematem jako próby naprawienia polskich znaków https://www.ipsbeyond.pl/blogs/entry/98-jak-poradzi%C4%87-sobie-z-kodowaniem-znak%C3%B3w-przy-aktualizacji-ipboard-3-do-ips-community-suite-4/?tab=comments#comment-72

    Znalazłem metodę jak to można naprawić: 

    Przykład:

    UPDATE `ipb_forums_posts` SET `post` = REPLACE(`post` , 'Ä™', 'ę'), `post` = REPLACE(`post` , 'Å‚', 'ł'),  `post` = REPLACE(`post` , 'Å›', 'ś'),  `post` = REPLACE(`post` , 'Ä', 'ą'),  `post` = REPLACE(`post` , 'Ä', 'ą'), `post` = REPLACE(`post` , 'Å„', 'ń'), `post` = REPLACE(`post` , 'ź', 'ź'),  `post` = REPLACE(`post` , 'Å‚', 'ł'),  `post` = REPLACE(`post` , 'ó', 'ó');

    Potrzebuję jeszcze nazw tabel, które odpowiadają za wyświetlanie tych nagłówków.

    image.thumb.png.3c551cf90401c35e830f17acf9601e1e.png

     

×
×
  • Create New...

Important Information

W celu świadczenie usług przez nasz Serwis na najwyższym poziomie, w ramach Serwisu wykorzystujemy pliki Cookies (tzw. ciasteczka). Korzystając ze stron Serwisu IPSBEYOND.PL bez zmiany ustawień przeglądarki będą one zapisane w pamięci urządzenia. Jeżeli nie dokonacie Państwo zmiany ustawień przeglądarki internetowej to wyrażacie zgodę na zapisywanie plików Cookies.